Top > FAQ > 12

 * 同じ商品、同じ記事が重複投稿されるのですが? [#w74cc3ea]
 -ページ: [[FAQ]]
 -種別: その他
 -投稿日: 2006-01-05 (Thu) 04:43:09
 
 ** 質問 [#ee4ffcb4]
 ・質問
 
 同じ商品の同じページが重複して、何ページもできてしまいます。これはなぜでしょうか?エラーですか?
 
 
 ** 回答 [#d708f54c]
 ・答え
 
 商品が重複投稿される件について
 
 【現象】
 
 まれに、同じ商品が何度も自動投稿されるブログがあります。(全体の5%ほど)
 原因を調査しましたところ、以下に該当することがあきらかになりました。
 
 
 【原因】
 
 アフィリエイトビルダーから外部投稿した際、正常に投稿された場合には『投稿成功』として
  投稿された記事の通し番号(ID)が返り値として戻ってきます。(これは再投稿の時に必要)
 
  しかし、次のようなコードがエラーとして返してくるMTがあります。
 
  1)Could not post (Didn't receive 200 OK from remote server. (HTTP/1.1 302 Found)) 
 MTか、もしくはサーバ内部で不具合がおこっております。。
 
 
  2)Could not post (Invalid return payload: enable debugging to examine incoming payload) 
     内部でエラーが起こっています
 
 
  3)Could not post (Didn't receive 200 OK from remote server. (HTTP/1.1 500 Internal Server Error)) 
     CGIが正常に動作していません。
 
 
  4)Could not post (Invalid blog ID '2')
 これは、MTを再インストールしたのちに、こちらで初期化されていないために、ブログIDが一致していないパターンと思われます
 
 
 上記のようなエラーが出た場合、通常は「投稿失敗」です。(記事が投稿されない方のパターン)
 
 
 しかし、まれに「投稿されているのに上記のエラーを返すMTがある」のです。
  そうすると、こちらのサービスは、次回の巡回時に再投稿を試みるので
  結果として延々と同じデータが投稿されることになります。
 
 
 この現状は今までも数件報告がありましたが、こちらのツールからは原因に手をつけられないものです。
 (こちらのツールのエラーではありません。)
 
 
 いままで、いくつか同様の相談がございましたが、MTの再インストールでほとんどが解決されております。
 
 
 【解決策】
 
 MTを再インストールしていただく方法しか、今のところ解決策がありません。
 (MTを再インストールの際には、ブログのデータを一旦削除する必要がありますので、ブログ削除の手順に従ってメールを下さい)
 
 
 もし、MTを再インストールしても同じエラーが出る場合は、こちらでは手の施しようがありません。
 
 その際には、サービス料金を全額返金させていただきます。
 
 よろしくお願いいたします。
 
 #comment